[Symfony 2] Erreur : Please install the ‘intl’ extension for full localization capabilities

L’erreur complet :

The Symfony\Component\Locale\Stub\StubNumberFormatter::parse() method’s argument $type value 2 behavior is not implemented. Please install the ‘intl’ extension for full localization capabilities.

Il apprêt avec l’utilisation des attributs de type integer dans une Entity, pour résoudre le problème il suffit d’installé la lib php5-intl
Sous ubuntu, il suffit de lancer :

sudo apt-get install php5-intl

N’oublier surtout pas de redémarrer apache à la fin de l’installation :

sudo service apache2 restart

 
Une autre erreur peut être corrigée avec cet installation, cet erreur apparaît avec les fields type : country, language, locale.

Fatal error: Class ‘ResourceBundle’ not found in vendor/symfony/src/Symfony/Component/Locale/Locale.php on line 46
Publicités

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s